MENU

MAMPでPHP4とPHP5の切替がGUIから出来ない

なぜか原因はわからないけど、MAMPのGUIからPHP4か5の切替ができなくなってた。

MAMPのGUI – [環境設定]-[PHP]から
PHPのバージョンのどちらかを選べるのですが、いくら設定をしてサーバー再起動したりしても変わってくれなかった。
(私の場合はPHP4のまま)

仕方無いので、直接設定ファイルを触ったら解決したのでメモ。

/Applications/MAMP/apache/conf/httpd.conf 内で以下の部分を修正
LoadModule php5_module modules/libphp5.so
#LoadModule php4_module modules/libphp4.so

動かしたく無い方を”#”でコメントする事で切替ができました。

この記事を書いた人

Web制作の日々のブログです。
主に自分用のメモが大半。

コメント

コメントする

*

目次
閉じる